Duramax Diesels Forum Truck of the Week
  #1  
Old 03-20-2009, 12:40 PM
lotsofmiles lotsofmiles is offline
Father of the Van

 
Join Date: Dec 2008
Location: Michigan
Truck: Express Van
Engine: 4.8
Transmission: Automatic
Posts: 3,362

Default HELP! oil pressure low! gauge dropped to nothing!

cruising on the eway my oil pressure gauge dropped to nothing. I stopped the truck. everything looks and sound normal and I have enough oil in it. what should I check next. feel free to call, i'm sitting in a parkinglot trying to figure this out. thanks all
Posted via Mobile Device
__________________
Express VAN

Quote:
Originally Posted by Jeremy Clarkson View Post
Some say he was conceived in a cargo van

Last edited by lotsofmiles; 03-20-2009 at 12:43 PM.
Reply With Quote
  #2  
Old 03-20-2009, 12:43 PM
bullfrogjohnson's Avatar
bullfrogjohnson bullfrogjohnson is offline
Big Girl!
 
Join Date: Nov 2006
Location: Locust, NC
Truck: 03 white ccsb lb7
Engine: 6.6 duramax
Transmission: Automatic
Posts: 4,980

Default

Noc check engine lights? I beilive if the oil pressure drops below 40psi the CEL will come on.

This is in your 07 right?
__________________
Travis
03 CCSB lb7
06 2500hd ECLB 6.0 gasser

2010 Straight Diesel 2.8 Points Champion
special thanks:
B&B Pulling and Greene's Diesel Performance, Fully Spooled Motorsports, Johnboy, Simon, Ed, ProFab Performance, Hamilton Cams, Extreme Prejudice Racing, Ridge Runner Diesel
Reply With Quote
  #3  
Old 03-20-2009, 12:46 PM
lotsofmiles lotsofmiles is offline
Father of the Van

 
Join Date: Dec 2008
Location: Michigan
Truck: Express Van
Engine: 4.8
Transmission: Automatic
Posts: 3,362

Default

Yes in the LBZ, no codes, no cel. just the display on the dash said oil pressure low.

The gauge dropped to nothing.

Engine sounds normal, and there is plenty in it, no signs of a leak or blow out that I can see yet. I ran it about a mile or 2 to get off the eway into a prk lot.

About 3000 miles since last oil change.

Been cruising the eway all day no problems till now
__________________
Express VAN

Quote:
Originally Posted by Jeremy Clarkson View Post
Some say he was conceived in a cargo van
Reply With Quote
  #4  
Old 03-20-2009, 12:47 PM
lotsofmiles lotsofmiles is offline
Father of the Van

 
Join Date: Dec 2008
Location: Michigan
Truck: Express Van
Engine: 4.8
Transmission: Automatic
Posts: 3,362

Default

Bad sensor? where is it?
just a thought
__________________
Express VAN

Quote:
Originally Posted by Jeremy Clarkson View Post
Some say he was conceived in a cargo van
Reply With Quote
  #5  
Old 03-20-2009, 12:47 PM
bullfrogjohnson's Avatar
bullfrogjohnson bullfrogjohnson is offline
Big Girl!
 
Join Date: Nov 2006
Location: Locust, NC
Truck: 03 white ccsb lb7
Engine: 6.6 duramax
Transmission: Automatic
Posts: 4,980

Default

You dont have EFI live or anything do you?
__________________
Travis
03 CCSB lb7
06 2500hd ECLB 6.0 gasser

2010 Straight Diesel 2.8 Points Champion
special thanks:
B&B Pulling and Greene's Diesel Performance, Fully Spooled Motorsports, Johnboy, Simon, Ed, ProFab Performance, Hamilton Cams, Extreme Prejudice Racing, Ridge Runner Diesel
Reply With Quote
  #6  
Old 03-20-2009, 12:48 PM
bullfrogjohnson's Avatar
bullfrogjohnson bullfrogjohnson is offline
Big Girl!
 
Join Date: Nov 2006
Location: Locust, NC
Truck: 03 white ccsb lb7
Engine: 6.6 duramax
Transmission: Automatic
Posts: 4,980

Default

Quote:
Originally Posted by lotsofmiles View Post
Bad sensor? where is it?
just a thought
Sensor is on the drivers side of the block under the exhaust manifold towards the back of the block. Should be a 3 wire plug
__________________
Travis
03 CCSB lb7
06 2500hd ECLB 6.0 gasser

2010 Straight Diesel 2.8 Points Champion
special thanks:
B&B Pulling and Greene's Diesel Performance, Fully Spooled Motorsports, Johnboy, Simon, Ed, ProFab Performance, Hamilton Cams, Extreme Prejudice Racing, Ridge Runner Diesel
Reply With Quote
  #7  
Old 03-20-2009, 12:51 PM
lotsofmiles lotsofmiles is offline
Father of the Van

 
Join Date: Dec 2008
Location: Michigan
Truck: Express Van
Engine: 4.8
Transmission: Automatic
Posts: 3,362

Default

I got efi with me, but dont know how to use it...
banks 6gun says no obdii codes
__________________
Express VAN

Quote:
Originally Posted by Jeremy Clarkson View Post
Some say he was conceived in a cargo van
Reply With Quote
  #8  
Old 03-20-2009, 12:53 PM
Kat's Avatar
Kat Kat is offline
Wicked Witch of the West

 
Join Date: Aug 2006
Location: Norco, CA
Truck: 2006 GMC CC/SB
Transmission: Automatic
Posts: 19,767

Default

Pat says check the bale connectors. He said it happened to Blue once.

When we lost the oil pump in Casper it would clatter when he started it.
__________________

Satan 2010 ZR1


Blue Meanie 02 Z06 11.36 @ 120.67 448 rwhp/411 tq AFR H/C

Wendy 06 GMC LBZ CC/SB EFI "Rat Posion", Sun Coast trans, SC 1057 & Transgo JR by MikeL, true downpipe, Banks Ram-Air SD sleeves 12.50 @ 107.51


Big Blue04 GMC LLY 3500 SRW CC LB 4x4 DA Big Blue 13.12 @ 103.93 466RWHP/928TQ. PPE LLY extreme tune, VA Box, SC III by Inglewood Trans, 4" straight pipe, Super Diesel Tie Rod supports and Manifold, Trippin Pickup, Cognito Braces, FuzzyDice.

McRat's toy-2005 GMC "Casper 2" 2500HD 4wd Xcab SB Mike L. LLY 2 trans, McRat tuning 10.59 @ 128.9


Reply With Quote
  #9  
Old 03-20-2009, 12:54 PM
lotsofmiles lotsofmiles is offline
Father of the Van

 
Join Date: Dec 2008
Location: Michigan
Truck: Express Van
Engine: 4.8
Transmission: Automatic
Posts: 3,362

Default

Quote:
Originally Posted by bullfrogjohnson View Post
Sensor is on the drivers side of the block under the exhaust manifold towards the back of the block. Should be a 3 wire plug
I see the 2 wire sensor plugged into oil pan, followed that up to a 3wire sensor. is that it?
it's still plugged in wires are fine.
__________________
Express VAN

Quote:
Originally Posted by Jeremy Clarkson View Post
Some say he was conceived in a cargo van
Reply With Quote
  #10  
Old 03-20-2009, 12:54 PM
bullfrogjohnson's Avatar
bullfrogjohnson bullfrogjohnson is offline
Big Girl!
 
Join Date: Nov 2006
Location: Locust, NC
Truck: 03 white ccsb lb7
Engine: 6.6 duramax
Transmission: Automatic
Posts: 4,980

Default

Quote:
Originally Posted by lotsofmiles View Post
I got efi with me, but dont know how to use it...
banks 6gun says no obdii codes
But you have a laptop and all the EFI software installed right? If so I can walk you through how to read oil pressure to determine if its a bad sensor or the oil pump took a dump or you cluster messed up
__________________
Travis
03 CCSB lb7
06 2500hd ECLB 6.0 gasser

2010 Straight Diesel 2.8 Points Champion
special thanks:
B&B Pulling and Greene's Diesel Performance, Fully Spooled Motorsports, Johnboy, Simon, Ed, ProFab Performance, Hamilton Cams, Extreme Prejudice Racing, Ridge Runner Diesel

Last edited by bullfrogjohnson; 03-20-2009 at 12:56 PM.
Reply With Quote
  #11  
Old 03-20-2009, 12:55 PM
duratothemax's Avatar
duratothemax duratothemax is offline
<--- slippery roads
 
Join Date: Aug 2006
Location: Wyoming
Truck: duh
Engine: duh
Posts: 7,440
Default

no it wont set a code, it will just give a warning in the DIC and start dinging at you.

Most likely a oil press sensor issue. The oil press sensor is kinda tricky to get to, its up behind the oil cooler sort of. As a quick and dirty check, you can crack open the oil line feeding the turbo, fire up the truck, and see if oil comes out. If oil comes out then you have pressure and its just a bad sending unit.

ben
__________________
2005 chevy dmax/allison - "HOT AND DANGEROUS" - built engine and trans with parts/advice/help from the best...MikeL.Trippin.Schulte.IdahoRob.TimHecker-St.JoeDiesel.McRat.juddski.dmaxfireman.BigDipper.M PI.Bobo.GMC-2002-DMAX.fingers.RickDLance.dmaxalliTech.EFILive...sor ry no times yet, I just wanted to reserve the truck-name

BT DieselWorks, LLC - Full transmission/engine builds - EFILive tuning - full service for GM gas/diesel trucks and SUVs - Allison lockup controllers - Allison tapshift kits - dmax/alli/GM gasser standalone harnesses - custom truck electronic gadgets

All products available for sale through our online store at www.btdieselworks.com

Be sure to "like" us on Facebook at www.facebook.com/BTDWorks
Reply With Quote
  #12  
Old 03-20-2009, 12:55 PM
Vrabel's Avatar
Vrabel Vrabel is offline
TOYAHOLIC
 
Join Date: May 2008
Location: Hewitt, NJ
Truck: '01 Silverado 2500HD
Engine: 6.6 DURAMAX
Transmission: Automatic
Posts: 3,733

Default

did you actually check oil? Thats how I knew I needed injectors finnally, because crankcase was filled with fuel.
__________________
R.I.P.
'01 Silverado 2500HD. Not Quite Stock.
Sheet Metal Workers Local #22
Creatures Of The Night Performance
ProFab Performance
Reply With Quote
  #13  
Old 03-20-2009, 12:56 PM
duratothemax's Avatar
duratothemax duratothemax is offline
<--- slippery roads
 
Join Date: Aug 2006
Location: Wyoming
Truck: duh
Engine: duh
Posts: 7,440
Default

Quote:
Originally Posted by bullfrogjohnson View Post
But you have a laptop and all the EFI software installed right? If so I can walk you through how to read oil pressure to determine if its a bad sensor or the oil pump took a dump
how is efilive going to tell you if the sensor is bad...?

the ECM and the instrument cluster [and efilive] all get their readings from the same sensor...

ben
__________________
2005 chevy dmax/allison - "HOT AND DANGEROUS" - built engine and trans with parts/advice/help from the best...MikeL.Trippin.Schulte.IdahoRob.TimHecker-St.JoeDiesel.McRat.juddski.dmaxfireman.BigDipper.M PI.Bobo.GMC-2002-DMAX.fingers.RickDLance.dmaxalliTech.EFILive...sor ry no times yet, I just wanted to reserve the truck-name

BT DieselWorks, LLC - Full transmission/engine builds - EFILive tuning - full service for GM gas/diesel trucks and SUVs - Allison lockup controllers - Allison tapshift kits - dmax/alli/GM gasser standalone harnesses - custom truck electronic gadgets

All products available for sale through our online store at www.btdieselworks.com

Be sure to "like" us on Facebook at www.facebook.com/BTDWorks
Reply With Quote
  #14  
Old 03-20-2009, 12:56 PM
lotsofmiles lotsofmiles is offline
Father of the Van

 
Join Date: Dec 2008
Location: Michigan
Truck: Express Van
Engine: 4.8
Transmission: Automatic
Posts: 3,362

Default

Quote:
Originally Posted by Kat View Post
Pat says check the bale connectors. He said it happened to Blue once.

When we lost the oil pump in Casper it would clatter when he started it.
Bale connectors? feel free to explain
__________________
Express VAN

Quote:
Originally Posted by Jeremy Clarkson View Post
Some say he was conceived in a cargo van
Reply With Quote
  #15  
Old 03-20-2009, 12:57 PM
bullfrogjohnson's Avatar
bullfrogjohnson bullfrogjohnson is offline
Big Girl!
 
Join Date: Nov 2006
Location: Locust, NC
Truck: 03 white ccsb lb7
Engine: 6.6 duramax
Transmission: Automatic
Posts: 4,980

Default

Quote:
Originally Posted by duratothemax View Post
how is efilive going to tell you if the sensor is bad...?

the ECM and the instrument cluster [and efilive] all get their readings from the same sensor...

ben
it wont I was typing in a hurry
__________________
Travis
03 CCSB lb7
06 2500hd ECLB 6.0 gasser

2010 Straight Diesel 2.8 Points Champion
special thanks:
B&B Pulling and Greene's Diesel Performance, Fully Spooled Motorsports, Johnboy, Simon, Ed, ProFab Performance, Hamilton Cams, Extreme Prejudice Racing, Ridge Runner Diesel
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 11:58 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vB.Sponsors